Metatrader 4 Build 1090 issue(s) ...

#1
Since it is repeating itself over and over, here is a description and a "fix" for one of the nasty bugs of build 1090 of mt4
_____________________________________

From time to time you will have a case that you attach an indicator to a chart and nothing is display. If you open the data window, you shall see that the data is at correct places, but nothing is displayed on the chart

To fix : edit the code - change anything (random change will do) - compile the code - undo the change you did (reverting to the original code) - compile again. It will display


Re: Metatrader 4 Build 1090 issue(s) ...

#3
mladen wrote:
Sun May 28, 2017 5:52 pm
Since it is repeating itself over and over, here is a description and a "fix" for one of the nasty bugs of build 1090 of mt4
_____________________________________

From time to time you will have a case that you attach an indicator to a chart and nothing is display. If you open the data window, you shall see that the data is at correct places, but nothing is displayed on the chart

To fix : edit the code - change anything (random change will do) - compile the code - undo the change you did (reverting to the original code) - compile again. It will display
I'm sorry but I do not understand what to do !

Re: Metatrader 4 Build 1090 issue(s) ...

#4
gtudor wrote:
Mon May 29, 2017 8:55 pm
mladen wrote:
Sun May 28, 2017 5:52 pm
Since it is repeating itself over and over, here is a description and a "fix" for one of the nasty bugs of build 1090 of mt4
_____________________________________

From time to time you will have a case that you attach an indicator to a chart and nothing is display. If you open the data window, you shall see that the data is at correct places, but nothing is displayed on the chart

To fix : edit the code - change anything (random change will do) - compile the code - undo the change you did (reverting to the original code) - compile again. It will display
I'm sorry but I do not understand what to do !
I can not explain in the simpler way
Please read that post again


Re: Metatrader 4 Build 1090 issue(s) ...

#6
gtudor wrote:
Mon May 29, 2017 9:06 pm
mladen wrote:
Mon May 29, 2017 9:01 pm


I can not explain in the simpler way
Please read that post again
I succeeded .
Thank you !
Well done gtudor...
I have changed the code from 32 to 34, then reversed it back to 32, but it failed.
Then I changed the sma to smma, reopened the platform, and it failed.
Changed 7 different parts of the code and failed every time and still does not load .
Changed the name of the indi but still did not work.
Could you tell me which bit you changed please?
Many thanks
TEAMTRADER

Re: Metatrader 4 Build 1090 issue(s) ...

#7
TEAMTRADER wrote:
Mon May 29, 2017 10:55 pm
gtudor wrote:
Mon May 29, 2017 9:06 pm


I succeeded .
Thank you !
Well done gtudor...
I have changed the code from 32 to 34, then reversed it back to 32, but it failed.
Then I changed the sma to smma, reopened the platform, and it failed.
Changed 7 different parts of the code and failed every time and still does not load .
Changed the name of the indi but still did not work.
Could you tell me which bit you changed please?
Many thanks
TEAMTRADER
I opened the file with "Modified"
I wrote on the last empty line 1234
We compiled
Open again with << modified >>
I deleted 1234
We compiled
And it was ok!

Re: Metatrader 4 Build 1090 issue(s) ...

#8
By 'complied' I assume it means saving the amended indicator and closing the platform
If this assumption is correct, I did exactly as you said but there is obviously something wrong with my platform so I have to concede defeat with this indicator.
Thank you again for taking the time - appreciated.
TEAMTRADER

Re: Metatrader 4 Build 1090 issue(s) ...

#9
TEAMTRADER wrote:
Mon May 29, 2017 11:39 pm
By 'complied' I assume it means saving the amended indicator and closing the platform
If this assumption is correct, I did exactly as you said but there is obviously something wrong with my platform so I have to concede defeat with this indicator.
Thank you again for taking the time - appreciated.
TEAMTRADER
No
Compiling means opening an editor and pressing the compile button or choosing file->compile or simply pressing F7 while in editor. If you do as described, it works
________________________________________________
I will repeat once again : it has nothing, but nothing at all to do with the code of the indicator (or any indicator as a matter of fact) - that is a bug of build 1090


Attachments 15
  1. Similar Topics

    1. MT4 Update Sep 13: Build 1220

      0 Replies 1423 Views

      by Jimmy, Sun Sep 15, 2019 3:01 pm in Trading Platform Discussion

      0 Replies
      1423 Views
    2. 1-1 scaling issue in 1M TF

      3 Replies 266 Views

      by shaileshm, Wed Sep 09, 2020 4:30 pm in MT4 Indicators

      3 Replies
      266 Views

Return to “Trading Platform Discussion”