NO LINKS, SOURCE CODE REQUESTS OR MODIFICATION OF DECOMPILED INDICATORS. To avoid post deletion please follow the rules.

Re: Moving Average indicators for MT4

#1231
mrtools wrote:
Tue Aug 11, 2020 9:44 am
mades wrote:
Tue Aug 11, 2020 6:41 am


Wow you upgraded it way beyond my request, thank you.

Edit: Unfortunately it shows different results than the old 8.9 one. On the pic, the thinner line is 8.9, thicker new 9.2 with identical settings. Tested on EMA with both adaptive/double smoothed on/off and filter set both to all or average value. Also it's name-locked.
Do not have the code for 8.9 anymore so not sure what the difference is, so guess stuck with 8.9 unless i can figure out what is going on with it.

Edit - Found some differences in the code for the filter and double smoothing, now it's closer to version 9.1 but please check for version 8.9 when you get a chance.
Unfortunately, the differences are still there. Thin line is 8.9 thick line is 9.3. I tested with the "old" 9.2 and it yields exactly the same results as 8.9.
USTECHIndexM1.png


Re: Moving Average indicators for MT4

#1232
marwilli wrote:
Tue Aug 11, 2020 5:36 pm
mrtools wrote:
Tue Aug 11, 2020 9:44 am

thank you mrtools :-)

an annotation for other user.
if you donwload vers 9.3 you must change the file after the word "alerts".
behind this word you must have 2 space keys otherwise you get fault message like below
Hmm are you renaming the file bro? I've just downloaded it using Chrome and had no issues like that. What browser are you using? :think:
All Moving Averages indicator non-repainting MT4.png
Trade with the broker that supports our work. FBS are offering $100 to get you started! Click, here to begin live trading, today.
No commissions are earned by Forex-station.

Re: Moving Average indicators for MT4

#1233
marwilli wrote:
Tue Aug 11, 2020 5:36 pm
if you donwload vers 9.3 you must change the file after the word "alerts".
behind this word you must have 2 space keys otherwise you get fault message like below
??? did u rename it................... i didnt get that error on me

Re: Moving Average indicators for MT4

#1234
Jimmy wrote:
Tue Aug 11, 2020 8:33 pm
marwilli wrote:
Tue Aug 11, 2020 5:36 pm
Hmm are you renaming the file bro? I've just downloaded it using Chrome and had no issues like that. What browser are you using? :think:
hm ???? i use firefox actual version. I´ve posted this info, because some time ago, other user have this problem too.
maybe it is a browser problem. ok I don´t know it exactly.
I will test it with chrome and opera again.
thanks all for the feedback. :-)
I never rename indies. because if I have a problem or question I didn´t find the indy here again without original name.

Re: Moving Average indicators for MT4

#1235
moey_dw wrote:
Tue Aug 11, 2020 9:14 pm
marwilli wrote:
Tue Aug 11, 2020 5:36 pm
if you donwload vers 9.3 you must change the file after the word "alerts".
behind this word you must have 2 space keys otherwise you get fault message like below
??? did u rename it................... i didnt get that error on me
hi moey,
see my answer below to Jimmy.
thanks for your feedback :-)


Re: Moving Average indicators for MT4

#1236
mades wrote:
Tue Aug 11, 2020 7:48 pm
mrtools wrote:
Tue Aug 11, 2020 9:44 am


Do not have the code for 8.9 anymore so not sure what the difference is, so guess stuck with 8.9 unless i can figure out what is going on with it.

Edit - Found some differences in the code for the filter and double smoothing, now it's closer to version 9.1 but please check for version 8.9 when you get a chance.
Unfortunately, the differences are still there. Thin line is 8.9 thick line is 9.3. I tested with the "old" 9.2 and it yields exactly the same results as 8.9.
What settings are you using for both, because when I overlay them they are the same with identical settings.

Re: Moving Average indicators for MT4

#1238
marwilli wrote:
Tue Aug 11, 2020 10:38 pm
moey_dw wrote:
Tue Aug 11, 2020 9:14 pm


??? did u rename it................... i didnt get that error on me
hi moey,
see my answer below to Jimmy.
thanks for your feedback :-)
somting strange going on.............. saw some reply of another guy with same issue with a file the other day??? wonder what making these rename error happen if no one rename!!! mrtool said the pc may rename it or something?? is it right or is it something the browser doing................... are u using chrome or fire fox?? aaaaah!!! :stressed: :stressed: :stressed:

Re: Moving Average indicators for MT4

#1239
mrtools wrote:
Tue Aug 11, 2020 10:40 pm
mades wrote:
Tue Aug 11, 2020 7:48 pm


Unfortunately, the differences are still there. Thin line is 8.9 thick line is 9.3. I tested with the "old" 9.2 and it yields exactly the same results as 8.9.
What settings are you using for both, because when I overlay them they are the same with identical settings.
Here there are side-by-side, thin is 8.9 thick is 9.3. As long as I change price type to close (or HE close), they become identical.
avg.png

Re: Moving Average indicators for MT4

#1240
mades wrote:
Tue Aug 11, 2020 11:55 pm
mrtools wrote:
Tue Aug 11, 2020 10:40 pm


What settings are you using for both, because when I overlay them they are the same with identical settings.
Here there are side-by-side, thin is 8.9 thick is 9.3. As long as I change price type to close (or HE close), they become identical.
Oh okay showing the prices rang my bell on the heiken ashi prices had modified them to try and speed them up, on heiken ashi itself, it sometimes changes trend a bar early, but probably not good to use on the prices. Anyway all should be well with this version. I apologize for the hassle.
averages - mtf - alerts 9.4.ex4
(169.13 KiB) Downloaded 224 times


  1. Similar Topics

    1. RE: Moving average alert 9.0

      2 Replies 580 Views

      by radeos, Wed Sep 09, 2020 8:28 am in Express Coding & Commercial Services

      2 Replies
      580 Views
    2. Moving average alert indicator

      2 Replies 3447 Views

      by Hani, Thu Jun 27, 2019 6:38 am in Coding Help

      2 Replies
      3447 Views

Return to “MT4 Indicators”