.

Re: Wave trend Oscillator

#41
mrtools wrote:
Thu Jun 21, 2018 2:39 am
traderduke wrote:
Thu Jun 21, 2018 2:14 am


INSANE situation:
MrTools
I appreciate the wave Osc but I appear to have a MT4 problem that persist. This has been happening to various platforms, operating systems and computers which is why I believe it is a MT4 problem.
I copy a fill into the indicator folder, I can see it when I sort on the folder but it’s not viewed in the navigator. I have refreshed & restarted the platform several times. This happens with both exe and source files AT TIMES but seems to occur more frequently with exe files. Maybe a month later the file will appear in the navigator.
I can copy 20 files of various types (source & Exe) into the folder and ultimately 1 or 2 won’t show up in the navigator. The interesting thing is if I create a template on another platform with that indicator and load the template onto the BAD platform the indicator does appear on the chart of the BAD platform but still will not show up on the navigator.
Any Ideas, please. This is driving me nuts trying to keep track of what appears where.
Appreciate any sane idea
Ray
Usually I start having problems like that when I have too many indicator files in my indicator folder, usually if i delete some of the files it gets better.
Mrtools
Thanks, the threshold use to be a 1000 looks like it’s 1500, sometimes, at this time.
I’ll test the wave indicator.
Again thanks
ray


Re: Wave trend Oscillator

#42
Mrtools
I believe the WT with the source code would sever me best, If you could convert it to a MTF and MAXBARS.

This has the old array coding it needs an update to make the code more efficient, if you could be so kind it would be helpful or you could strip away the priority items and give me the source code of your stripped indicator. The others eat up a lot of CPU especially when I use 3 or 4. I don't need the price & method extravaganza .

I believe I could ,copy & paste my way through the code to get me where I want to be if you would be so kind as to add the above items..

The other non source code indicators aren't flexible enough without the source code.

Appreciate your interest & help
Ray
trend-wave-oscillator.mq4
(15.06 KiB) Downloaded 124 times

Re: Wave trend Oscillator

#43
mrtools wrote:
Tue Jun 19, 2018 2:46 am
traderduke wrote:
Sun Jun 17, 2018 5:20 am
Mrtools/mladen
I know that it’s been a while but I still believe that this is an exceptional indicator if I can get some flexibility on the trend which is in buffer 13. Right now it is permanently set at ObL1 & OsL1. I believe I saw recently that MT said he didn’t have the source file, please ask mladen for it.

1. Utopia1 would be to create 5 trends one for each input “Color change on” with flexibility on the if necessary trend.
2. Utopia2 would be to create 1 trend that reflects the input “Color change on” with flexibility on the if necessary trend.
3. Utopia3 would be to create 5 trends one for each input “Color change on”.
4. Utopia27- Provide the source file and I will attempt to use the power of my Paste & copy functions.
Could we at least make the levels for ObL1 & OsL1 flexible, I’ll try to work with it.
Appreciate any help on this matter.
Ray
I am not sure but think the trend wave I have is close to the same as wave trend without the dots, but since I have been burned too many times will not release the source code but am willing to work on it to make any necessary changes, this version is bare bones with no coloring yet, so please help verify if they are the same for me and will continue.
mrtools
They are the same but;
1. one thing worries me, on your wave the CURRENT candle in the data window shows empty (see the chart). The prior candles are OK (see the chart).
2. Any chance you could make buffer8, which I'm not sure what it shows, read the signal cross (see the chart).

I appreciate your offer

thank you
Ray


8-5-2018 7-40-16 AM-mtwave-no-readings.png
no reading on current candle

8-5-2018 7-40-16 AM-mtwave-ok.png
your prior candle is exactly the same as wt1.5

8-5-2018 7-40-16 AM-mtwave-buffer8.png



trend wave osc(mtf + alerts).ex4
(55.51 KiB) Downloaded 84 times

Re: Wave trend Oscillator

#44
traderduke wrote:
Mon Aug 06, 2018 9:49 pm
mrtools wrote:
Tue Jun 19, 2018 2:46 am


I am not sure but think the trend wave I have is close to the same as wave trend without the dots, but since I have been burned too many times will not release the source code but am willing to work on it to make any necessary changes, this version is bare bones with no coloring yet, so please help verify if they are the same for me and will continue.
mrtools
They are the same but;
1. one thing worries me, on your wave the CURRENT candle in the data window shows empty (see the chart). The prior candles are OK (see the chart).
2. Any chance you could make buffer8, which I'm not sure what it shows, read the signal cross (see the chart).

I appreciate your offer

thank you
Ray



8-5-2018 7-40-16 AM-mtwave-no-readings.png



8-5-2018 7-40-16 AM-mtwave-ok.png



8-5-2018 7-40-16 AM-mtwave-buffer8.png





trend wave osc(mtf + alerts).ex4
Will see what i can do.

Re: Wave trend Oscillator

#45
mrtools wrote:
Tue Aug 07, 2018 4:03 am
traderduke wrote:
Mon Aug 06, 2018 9:49 pm


mrtools
They are the same but;
1. one thing worries me, on your wave the CURRENT candle in the data window shows empty (see the chart). The prior candles are OK (see the chart).
2. Any chance you could make buffer8, which I'm not sure what it shows, read the signal cross (see the chart).

I appreciate your offer

thank you
Ray



8-5-2018 7-40-16 AM-mtwave-no-readings.png



8-5-2018 7-40-16 AM-mtwave-ok.png



8-5-2018 7-40-16 AM-mtwave-buffer8.png





trend wave osc(mtf + alerts).ex4
Will see what i can do.

mrtools
I appreciate your help, is their anything I can do to expedite the process? I'm setting up the EA with 3 time frames, one of which is current which doesn't show up in the data window, that is my biggest concern at this time. Even the "trend wave oscillator" that I have the source code is empty on the current candle, are you getting anywhere with this problem?

I see mladen answering questions over at FF, the WT 1.5 is his indicator. Should I ask him to set the (WT 1.5 trend buffer #13) to trend the "signal level cross" instead of the "outer level cross"? I am confused as to who is connected to whom these days. I'm not trying to start any trouble but it seems to be an easy request but meeting a lot of resistance.

thank you
Ray


Re: Wave trend Oscillator

#46
traderduke wrote:
Fri Aug 10, 2018 5:04 am
mrtools wrote:
Tue Aug 07, 2018 4:03 am


Will see what i can do.

mrtools
I appreciate your help, is their anything I can do to expedite the process? I'm setting up the EA with 3 time frames, one of which is current which doesn't show up in the data window, that is my biggest concern at this time. Even the "trend wave oscillator" that I have the source code is empty on the current candle, are you getting anywhere with this problem?

I see mladen answering questions over at FF, the WT 1.5 is his indicator. Should I ask him to set the (WT 1.5 trend buffer #13) to trend the "signal level cross" instead of the "outer level cross"? I am confused as to who is connected to whom these days. I'm not trying to start any trouble but it seems to be an easy request but meeting a lot of resistance.

thank you
Ray
Probably best to ask Mladen, not sure how he did his version.

Re: Wave trend Oscillator

#47
mladen
Please give me one more chance to show my problem with WTO 1.5. This chart shows WTO 1.5 option 0,1,2 & 4 with visual changes that reflect the option but the buffer13 only shows option 4, what am I doing wrong???? or is something broke.



See attached chart;

8-10-2018 12-45-27 PM-wave 4 buffers.png

Re: Wave trend Oscillator

#48
traderduke wrote:
Sat Aug 11, 2018 3:09 am
mladen
Please give me one more chance to show my problem with WTO 1.5. This chart shows WTO 1.5 option 0,1,2 & 4 with visual changes that reflect the option but the buffer13 only shows option 4, what am I doing wrong???? or is something broke.



See attached chart;


8-10-2018 12-45-27 PM-wave 4 buffers.png
Buffer explorer (at least the one that I have written) is using default parameters - check that

Re: Wave trend Oscillator

#49
Mladen
I’m using your explorer from:
viewtopic.php?f=578623&t=8472117&p=1295 ... 1295357063

Yes, I see that it’s only reading the default, is there any chance you can change that??

I changed my EA to read the 13 buffer and the differences are clear! My problem, I should have trusted you and not the buffer reading from the start, I apologize for being so thick. I was telling you all along the buffer was only reading option4 but somehow we never connected.

I am using a GET function that works on several other MTFs. They calculate the MTF and current with no problem, is any chance you can tell me why WTO 1.5 creates the multi run problem when I use the current TF on the EA. This will be a major problem when I try to run 3 TFs, (current M5), M15 & M30.

Any help would be really appreciated
Thank you
Ray

PSS: By the way, my GET function gets the same reaction with mrtool's trend wave indicator when using current,
it must be some wave distortion, :lol: please help

See attached:
8-11-2018 9-53-42 AM-test get wto1.5.png


Who is online

Users browsing this forum: No registered users and 2 guests