Attachments forums

List of attachments posted on this forum.


All files on forums: 108646

Help with code change to fit EABuilder

Darkdoji, Wed Jun 27, 2018 7:45 pm

mr. tools and Mladen,

I bought an EABuilder software for generating EA's without any coding know-how. But for the main indicator I need to use in my EA design (please see attached MQL4 file) the EABuilder program generates an error message and does not compile code involving the attached indicator to work at all. The message is as follows: Important: Custom indicators used in any EA must be programmed in the new MQL4 language. The MQL4 language has changed significantly since build 600 at the beginning of 2014. Old, incompatible indicators include the functions init() and start(), whereas new indicators include the functions OnInit() and OnCalculate().

I got the attached indicator from mr, tools in Forex-TSD, I am aware there are "new formats" developed by Mladen that are improved versions. However, my request strictly concerns the version attached. It suits my needs exactly because it has specific properties I used in my EA design that are not available in the "new formats" - is it possible therefore to have the attached tool adjusted to work with my EABuilder? That is, is it possible to correct the code to eliminate the functions no longer in use in MT4 build 600 + while keeping the properties of the attached indicators as is?

I would be very grateful for help on this as this EA design depends almost completely on having this tool work with the EABuilder. Thanks in advance.
bbands stop mtf+alerts nmc.mq4
(9.06 KiB) Downloaded 736 times
All files in topic